Metku.net
http://metku.net/hwforum/

Wiring diagram and software
http://metku.net/hwforum/viewtopic.php?f=56&t=5640
Page 1 of 4

Author:  japala [ 07.08.2006 20:59 ]
Post subject:  Wiring diagram and software

I made an image that shows how I did the connections. I also included a piece of code, made by Jesper, for C++. Delphi code will be released if someone needs support for that developement tool.

Download the software

Download DLPortIO driver package for the parallel port and install it

Image

Author:  Opelrun [ 07.08.2006 23:06 ]
Post subject: 

Kiitoksia. Viellä kun näyttö tulisi, että pääsis testaileen :)

Ohjelmaa testasin kylmiltään, ni valittaa: "Sovelluksen käynnistäminen ei onnistu, koska DlPortIO.dll ei löytynyt. Sovelluksen uudelleenasentaminen saattaa korjata ongelman."

Mut eiköhän sit googlettamalla ajurit löydy...

Author:  malatory [ 09.08.2006 03:36 ]
Post subject: 

thanks for getting this up for everyone. It should help.

Author:  Maj0r_M0Dder [ 09.08.2006 09:45 ]
Post subject: 

japala kannattaa äkkiä patentoida idea ennen ku joku iso yritys tekee koneeseen tarkoitettuja nokia 6610 näyttöjä

Author:  TearTox [ 09.08.2006 19:35 ]
Post subject: 

Käykö tuo sama ohjain kaikkiin nokian värinäyttömalleihin vai onko tuo tarkoitettu vain 6610:n näytölle?

Author:  japala [ 09.08.2006 19:59 ]
Post subject: 

Tuohon on paha mennä sanomaan varmaa... Kysy Jesperiltä mitä tuumaisi. Joskus näkee, että porukka puhuu 6610/7250 näytöstä mutta mahtaako olla noin, että on identtiset näytöt kummassakin luurissa...

Author:  malatory [ 10.08.2006 06:42 ]
Post subject: 

I am hoping I could get some help with this.

I have everything wired up the same as your diagram. GRN to Paralle port is on pin 18.

When I use the C++ precomplied program with the DLL in that dir and in windows/system32. I keep getting this error.

Image

LPD port is set right

here is a link to some images of my work on it.
http://www.malatorymods.com/spider_v2_10.htm

Sorry I only know English.

Author:  japala [ 10.08.2006 07:30 ]
Post subject: 

I have all the necessary stuff on my hdd as I do a lot of programming so it is sometimes hard to say what is needed to get things working on some other computer. :)

I updated the first message in this thread to contain a DLPortIO driver package. Just download and install it and it should give you .sys and all the other needed pieces. Please, give us feedback on how it went. Thanks.

Author:  malatory [ 10.08.2006 17:56 ]
Post subject: 

japala wrote:
I have all the necessary stuff on my hdd as I do a lot of programming so it is sometimes hard to say what is needed to get things working on some other computer. :)

I updated the first message in this thread to contain a DLPortIO driver package. Just download and install it and it should give you .sys and all the other needed pieces. Please, give us feedback on how it went. Thanks.


I will do that tonight when I get home from work. I was looking at that file a few minutes ago as I was googling on the error.

They system I am running it on is a fairly clean system (Fresh install of XP, Gimp, 1-2 games)

My other system has all of the development packages on it.

Author:  thirdman [ 10.08.2006 19:36 ]
Post subject: 

Yay! Thank you, Japala!! :D

Author:  malatory [ 11.08.2006 00:33 ]
Post subject: 

WOOHOO LCD screen is working...

here is an image of a couple of test patterns.
Image

Just need to get my avatar loaded and I will be set for a little bit.

thanks Japala.. Loading the hole port95nt.exe is what was needed.

Author:  RCG_Savage [ 19.08.2006 08:22 ]
Post subject: 

Think this would work for the 3560 LCD screen?

Author:  Niroth [ 19.08.2006 14:55 ]
Post subject: 

Well I've gotten everything working, I can display the Test pattern and the "test 1" in the 8-bit display mode, but when i try and load an image to the screen it just comes out all garbelled and doesnt look anything like the source image. Any suggestions would be great.

Also I've noticed that the display pattern and "test 1" dont work in 12 or 16 bit modes the way they do in the 8 bit mode.

Ideas??

Jase

Author:  japala [ 19.08.2006 15:41 ]
Post subject: 

8-bit mode works with its own color palette. Inside the source code is a part that builds up the color table for the 8-bit mode. Other modes do not have this kind of color table. This is the reason why 8-bit mode can't display the images correctly if it doesn't know what kind of palette to use. In 8-bit mode you tell with index number what color you want to show but on those other modes you give the color values directly so no palette is needed on the display side.

Author:  Legacy [ 19.08.2006 16:56 ]
Post subject: 

Mikäköhän ohjain pitäisi tuolle 3310 näytölle hankkia?Riittääkö tuo , mikä on tässä samassa modissa?

Pitää varmaan laittaa Jesperille @mailia..

Page 1 of 4 All times are UTC + 2 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/